installation notes

External YUM repos needed

  • geekery
  • epel

Packages

  • nut
  • nut-cgi
  • nut-client
  • nut-xml
  • nut-hal

Installation commands

CentOS 5
  • i386:
    yum install nut nut-cgi nut-client
  • x86_64:
    yum install nut.x86_64 nut-cgi.x86_64 nut-client.x86_64
CentOS 6
  • i686:
    yum install nut nut-cgi nut-client
  • x86_64:
    yum install nut.x86_64 nut-cgi.x86_64 nut-client.x86_64

UDEV RULES installation instructions for USB UPSes

ln -s /lib/udev/rules.d/62-nut-usbups.rules /etc/udev/rules.d/62-nut-usbups.rules
udevcontrol reload_rules
udevtrigger
/etc/init.d/ups restart

nut build config

CentOS 5

Configuration for 2.61 version:

Configuration summary:
======================
build serial drivers: yes
build USB drivers: yes
build SNMP drivers: yes
build neon based XML driver: yes
build Powerman PDU client driver: yes
enable SSL development code: yes
enable libwrap (tcp-wrappers) support: yes
build CGI programs: yes
enable HAL support: yes
build and install documentation: no
build and install the development files: yes

Configuration for 2.64 version:

Configuration summary:
======================
build serial drivers: yes 
build USB drivers: yes 
build SNMP drivers: yes 
build neon based XML driver: yes 
enable Avahi support: yes 
build Powerman PDU client driver: yes 
build IPMI driver: no 
enable SSL development code: yes 
enable libwrap (tcp-wrappers) support: yes 
enable libltdl (Libtool dlopen abstraction) support: yes 
build CGI programs: yes 
enable HAL support: yes 
build and install documentation: no 
build and install the development files: no
CentOS 6

Configuration for 2.61 version:

Configuration summary:
======================
build serial drivers: yes
build USB drivers: yes
build SNMP drivers: yes
build neon based XML driver: yes
build Powerman PDU client driver: yes
enable SSL development code: yes
enable libwrap (tcp-wrappers) support: yes
build CGI programs: yes
enable HAL support: yes
build and install documentation: no
build and install the development files: yes

Configuration for 2.64 version:

Configuration summary:
======================
build serial drivers: yes 
build USB drivers: yes 
build SNMP drivers: yes 
build neon based XML driver: yes 
enable Avahi support: yes 
build Powerman PDU client driver: yes 
build IPMI driver: no 
enable SSL development code: yes 
enable libwrap (tcp-wrappers) support: yes 
enable libltdl (Libtool dlopen abstraction) support: yes 
build CGI programs: yes 
enable HAL support: yes 
build and install documentation: no 
build and install the development files: no
build-nut.txt · Last modified: 2012/07/22 23:26 by mspallacci
 
Except where otherwise noted, content on this wiki is licensed under the following license: CC Attribution-Share Alike 3.0 Unported
Recent changes RSS feed Donate Powered by PHP Valid XHTML 1.0 Valid CSS Driven by DokuWiki